...
POST No. 22041
USB2Dynamixel and Dynamixel Manager not working for AX-12 on PC
2010-05-17 15:49:00

Dear Sir or Madam,

I recently purchased 4 Dynamixel AX-12 and a USB2Dynamixel for PC  for a novel project I am currently working on.  Please note that I am not using a Robot kit or building a typical Robot.  Anyway I eventually managed to find the driver software for USB2Dynamixel – (in the USB2Dynamixel_software.zip download)   I downloaded the software and got the following:

(1)  The Dynamixel Manager (v0.93 beta) would recognise the AX-12 for a second or so and then crash
(2) Re-starting the Dynamixel Manager would make the system unstable and then that would eventually crash
(3) I have tried this on both Windows 7 and Windows XP and the same happens on both machines

I can confirm that the pin connections are correct for power (the LED on the AX-12 blinks as described in the manual) and the voltage (9.6v) is correct.  I searched the web for an answer and came up with some answers where someone had had the same issues.  At first the answer appeared to be to download the latest Dynamixel Software for PC v1.0.3 which it was claimed contained an updated version of the Dynamixel Manager (v0.97) – it didn’t.

 Anyway a further search on the web and the answer appeared to be to download RoboPlus (v 1.0.15.0) software and use the Dynamixel Manager installed with that product.  I downloaded and installed this but now I cannot connect to the AX12s at all.  There is a new Dynamixel Manager software in this download (v1.0.0) but now, it cannot recognise the AX-12 at all.  I can confirm:

(1)  I have connected the USB2Dynamixel correctly and the switch on the side of it is set for TTL
(2) The driver for the USB2Dynamixel is installed correctly
(3) I have followed the USB2Dynamixel Manual and set the Latency (ms) to “1” accordingly
(4) This does not work on either Windows XP or Windows 7

Please note that I am not using a robot kit and need to control the AX-12 from PC directly.  Can you help please?

Kind Regards

Kofi

2010-05-17 15:49:00
2010-05-18 00:36:00 Kofi
Hi Mike, I have already done that and I did not want to add this information to confuse matters further. The first time I used the Dynamixel Manager (0.93 beta) I was also toying with the Open Source C# project you mention and yes, I could light the LED. Really what I needed to do at this stage was to start doing things like configuring my AX-12s (changing the IDs for a networked connection) so I concentrated on trying to get Dynamixel Manager to work. Incidentally, since I downloaded RoboPlus and used that to try and confiigure the AX-12, now neither Dynamixel Wizard in the RoboPlus bundle nor the Open Source C# project can find my AX-12s. I have not even changed any IDs or anything. Power is OK (the AX-12 blinks when applied) and in Device Manager the USB2Dynamixel is working ok, but no application can locate any AX-12 now.
2010-05-18 00:36:00
Edit Delete
2010-05-18 06:36:00 MikeG
Give this a try.Download the binary (new) http://www.agaverobotics.com/services/dotnet/Dynamixel/default.aspxConnect 1 AX-12 and power.Using the Packet Tester, open the appropriate Dynamixel serial port at 1Mpbs.Click the toolbar icon that has a green arrow pointing up.Click "Yes", you want to reset all Dynamixels.The program will loop through all baud rates and send the reset command (loop 0 to 255)When the looping stops, enter a "1" in the ID field and click the "LED On" button.Hopefully, the LED will light up! Let me know how it goes.
2010-05-18 06:36:00
Edit Delete
2010-05-18 07:12:00 Kofi
Hi MikeG, Thanks for your help so far. I followed your instructions and downloaded the Packet Tester to do the reset. After it looped through all the baud rates I tried the LED On button and nothing happened. The status packet was: --> FF FF 01 04 03 19 01 DD Still no joy!
2010-05-18 07:12:00
Edit Delete
2010-05-19 15:25:00 Kofi
Hi MikeG, Thank you very much for all your help so far. I (think) I am getting somewhere, but not the ultimate destination (yet!). If I follow your instructions above I get the following: At #5 the AX-12 LED is NOT solid. Everything else from 6 to 12 is as indicated (the instructions "C" "A" and "G" all appear but of course at #13 the LED was not on in the first place so does not flicker and turn off. AX-12 still not working. Kind Regards Kofi
2010-05-19 15:25:00
Edit Delete
2010-05-22 20:45:00 Kofi
Oh and by the way, I have tried this now on two separate Windows machines now
2010-05-22 20:45:00
Edit Delete
Reply
웹에디터 시작 웹 에디터 끝