...
POST No. 2406762
OpenCR can not boot
2018-04-12 17:09:06 yoann_s

Hello,

First of all thank you for the work you have done and you are doing, Turtlebot3 is a great project.

I am working on the Turtlebot3 waffle pi. I followed all the steps from the emanual to setup the hardware but at this step  the robot is not moving when the SW1 and SW2 push buttons are pressed.

I have checked every connections several times.
I can see on the board only the USB and POWER leds are on.

However, everything else seems to work properly (LDS, BT-410, raspberry pi (ssh connection working)).
I tried to detect the connection between the raspberry pi and the OpenCR over USB:

  • with the IDE arduino but there was no ACM* port displayed
  • with lsusb command but nothing appeared related to the board

I also tried with several USB cables between the OpenCR and my laptop, but the result was the same.

In addition, I tried to use:

  • the recovery mode but there was no activity from the board (the STATUS led remains off)
  • it was the same with the DFU mode, the board did not appear with the lsusb command.


Do you have any idea to solve this problem? I am thinking to exchange the board due to a hardware fault.

Thanks in advance,
Yoann
 

2018-04-12 17:09:06
Solana
2018-04-13 09:37:07 Will Son

Hello,

Thank you for choosing TurtleBot3 for your research and development!

It seems like you haven't uploaded the firmware on OpenCR1.0.

Please follow the OpenCR setup instruction on your internet connected PC.

http://emanual.robotis.com/docs/en/platform/turtlebot3/opencr_setup/#opencr-setup


One thing that keeps bothering me is that the DFU mode should be available even without having firmware on the board.

If possible, try using another USB cable.


Please let us know if you need more help.

2018-04-13 09:37:07
Will Son
Reply
웹에디터 시작 웹 에디터 끝