...
POST No. 2406806
[USB2Dynamixel][XL430-W250-T] Issue: cannot update Dynamixel on R+ Manager (follow-up)
2018-05-15 04:32:11 Adrian_1

This is a follow-up of this thread: http://en.robotis.com/service/forum_view.php?slg=&page_type=&bbs_no=2406716

We have tried the solution suggested to us on the previous thread (pulling out the data pin from the Dynamixel cable), but we still have the same problems. Could there be other reasons why we can't manage to update the Dynamixel firmware?

2018-05-15 04:32:11
Adrian
2018-05-15 10:22:16 Kurt

It might help to see picture of your current setup.


I assume that you only have one servo plugged in?  I have seen issues like this when I have had multiple servos plugged in and some of them have the same id (ID #1).


I think I saw on your previous post that the baud rate was set to 115200?  I believe the default for the XL430... is 57600:

http://emanual.robotis.com/docs/en/dxl/x/xl430-w250/#baud-rate


Usually when I get mine, the first thing I do is to set the Baud rate to 1mbs, plus ID and the like.   Most of the time using my own programs to do so.

2018-05-15 10:22:16
Kurt
2018-05-15 10:53:32 Will Son

Hello Adrian,


First of all, please check if USB2Dynamixel is correctly selected for TTL mode.

Then, check 12V output from Dynamixel ports in OpenCR.

Please check if your connection is correctly made as below


 

2018-05-15 10:53:32
Will Son
2018-05-18 02:08:56 Adrian
Thanks a lot for your answers. First of all, here's a picture of the setup: 




I think we have already tried to modify the baud rate using an Arduino code at some point, but we can check again. 

We have already checked that TTL mode is selected. 

We will check again if the connection is the same as in the diagram you have attached and will write again soon.
2018-05-18 02:08:56
Adrian
2018-05-18 09:20:54 Kurt

What is running on the OpenCR board?  How is it powered?


i.e. is there something like 12v plugged into it? 


What is actually running on the OpneCR is important also as the DXL connectors power is controlled by an IO pin on it:   I believe it is:


  {GPIOF, GPIO_PIN_15,  NULL,     NO_ADC        , NULL   ,   NO_PWM       , NO_EXTI },  // 32 BDPIN_DXL_PWR_EN

So depending on what is running on the OPENCR, the IO pin may not have been set to turn on the power.
2018-05-18 09:20:54
Kurt
2018-05-19 19:34:19 Adrian

Hello again,


We have checked that the connection is correct according to the diagram.


We are powering the OpenCR with the 11.1V Lithium Polymer battery provided with the Turtlebot 3.


The software that is running on the OpenCR is the one designed for the Turtlebot 3 Burger.

2018-05-19 19:34:19
Adrian
Reply
웹에디터 시작 웹 에디터 끝