...
POST No. 2406809
Dynamixel Wizard cant find motors.
2018-05-17 04:20:31 johncgh22

Hi.


My name is Juan and I been working with Dynamixel Motors for some time, but recently I have some problems.

I´m using the USB2Dynamixel and 3 motors, AX-18, MX-64 and MX-28, but Dynamixel Wizard cant find them by any means. I tried find then using DynamixelSDK in LabVIEW and Python, but when I run the program, it crashes. I tried one by one, but still no success; also I tried in another computer but no luck either.


In my main computer, I'm using Windows 10 Version 1803, and on the Second computer it has Windows 10 version 1703, but Dynamixel Wizard cant find them in any of the two computers; both computers had RoboPlus 1 and on the second one it has and R+Manager, but it doesn´t find anything either. Sometimes it shows just the folder with the baud rate I previosly set, but when I run "Find Dynamixel" again, it doesnt show anything. I know that my motors are fine, I'm working with them since 2 years ago and just recently I got this problems, but if someone knows a way to verify if the signal is working, I'll try it.


If someone has the same problem, or has a solution, I´ll be happy to hear.


Thanks.


2018-05-17 04:20:31
johncgh22
2018-05-17 09:20:52 Will Son

Hello Juan,


I'd recommend to check belows.

- Is USB cable normal?

- Is USB2Dynamixel set to TTL mode.

- Is USB2Dynamixel detected from Windows Device Manager(Driver is correctly installed?)

- Can any of your Dynamixel be recovered by Firmware Recovery?

- Are you using the latest version of DynamixelSDK?


It is less likely to happen to all of them at the same time, so I assume malfunction of USB2Dynamixel or else communication IC of Dynamixel could be damaged.

Thank you.

2018-05-17 09:20:52
Will Son
2018-05-18 00:00:26 Kurt

Might also check power.  That is how are you powering the servos?  Have you verified that servos are getting power?  When you plug them in does the LED on servo flash?

2018-05-18 00:00:26
Kurt
2018-05-22 03:57:27 Juan Carlos Garcia

Hi:


Thanks for your answers, and according to them, I list my findings below:


  • My USB is normal, I cant find anything weird about it, when I connect it, LED turns ON
  • I´m using TTL mode, I dont use  the other two modes in USB2Dynamixel
  • Windows Device Manager detects when I connect it, even Dynamixel Wizard detects it, also when I use MATLAB, LabVIEW and Python.
  • I cant recover from Firmware Recovery, when I try to connect, it just stays in for a long time and doesnt detect the servo, in fact, any of them.
  • I was using Dynamixel SDK 3.5.3, but this week, I'll check it on SDK 3.5.4 (NOTE: Recently I know of version 3.6.0, I´ll try that too)
  • I know that servos are getting power, the only thing is that AX-18 blinks for a second, then it turns OFF, maybe I got a malfunction?
  • I´m powering the servos with this: SMPS2Dynamixel

Thanks!!

2018-05-22 03:57:27
Juan Carlos Garcia
2018-05-23 13:00:13 Will Son

Thank you for going through the check lists.

When powering Dynamixel, Red LED blinks once so it is normal as long as it does not keep blinking every second.

What I can think of is the failure of communication IC of your Dynamixel.

Please request Repair service and if possible, send your USB2Dynamixel with Dynamixel.

Thank you.

2018-05-23 13:00:13
Will Son
Reply
웹에디터 시작 웹 에디터 끝