...
POST No. 2406951
New XL430-W250-T DOES NOT MOVE
2018-09-06 04:35:27 Larcay

Just bought a XL430-W250-T actuator and i can't make it move. It responds to REBOOT and FACTORY RESET instructions but it doesn't move at all.

Anyone have a clue of what can be happening?

2018-09-06 04:35:27
Italo
2018-09-06 14:52:02 Will Son

Hi,

Could you tell us about your controller, power source, development environment?

If you can provide a picture or video, it'll be a great help to understand what went wrong.

Thank you.

2018-09-06 14:52:02
Will Son
2018-09-06 22:17:16 Kurt

Assuming you have the servo powered with something like 11-12v AND it is hooked up to some controller, and you are running some form of software.... As @Will Son noted, it is hard to give you any suggestions, with so little information.


In many cases my first guess would be power...   Either you are not supplying it or your controller (assuming you have one) has the ability to turn on and off the power to the servos (like OpenCR board).


Next guess again assuming you have proper software/hardware that is actually sending out data to the servo at the right baud rate...  Or depending on controller you are not sending the information to the right Buss, or you are not sending out Protocol 2 packets or ...


And depending on what mode the servo is configured for you have not enabled the Torque to the servo? http://emanual.robotis.com/docs/en/dxl/x/xl430-w250/#torque-enable

2018-09-06 22:17:16
Kurt
2018-09-07 07:31:06 Italo

Thanks for the replies.


Comunication is being done using a simple Serial Port Terminal and a USB to serial converter (cp2102). I'm only using TX pin of cp2102 linked on Dynamixel DATA pin once i could not yet implement the half duplex comunication. 


Dynamixel is been powered with 12V from an ATX power source.


Data is send byte after byte throught the Serial Port Terminal following Protocol 2 


CRC algoritm wore validated with the Protocol 2 exemples and i don't think it is the problem.


As i said the REBOOT and FACTORY RESET commands worked as could be seen by the different modes of led flickering.

2018-09-07 07:31:06
Italo
2018-09-07 08:36:22 Kurt

Again hard to say much with this information.  But hopefully @Will Son will understand more.


If it were me, I would work on getting a full half duplex working.  Probably cheapest and easiest way is to use something like the OpenCM9 board $10 without connectors...


But again don't see what packets you sent, nor the timing.... 


If I were hacking up something like this.  Probably the next thing I would do is to see if I was getting valid write packets that was working, was maybe write a simple program or script which tried to turn the Servos LED on and off maybe every half second... That is set register 65 to 1 and then to 0.... And see if the LED on the servo does this... This would verify that your packets are probably OK...


Once I got that working.  I would maybe try doing a move.   Again assuming Servo ID #1... I would send a write packet to turn on the servo torque... You should be able to verify this as once you do, you won't be able to turn the servo horn by hand...  Then I would try sending packet to set position.  Maybe do something like a sweep example...


But again lots of things could go wrong.


Example suppose you wrote the bytes: for setting up the servo to turn on Torque followed immediately by the command to set the position.  The position set may fail as the servo may very likely be in the state of wanting to send a status packet back to the servo to say, the command succeeded.  As such it may not be ready to receive the next command...


Also don't know what the servo will do when maybe it can not output the state packet as maybe your CP2102 is holding the IO pin either high or low.  Again I have not tried this so don't know.


Hopefully Will Son will have better suggestions.


2018-09-07 08:36:22
Kurt
2018-09-07 09:47:07 Will Son

Hi,


The USB-Serial converter you are using may not compatible with Dynamixel.

Dynamixel TTL voltage level is 5V and most USB-Serial device provides 3.3V level signals.

Please see the Communication Circuit below which is pulled up with 5V on the DATA line.

 

It is strongly recommended to use U2D2 first to make sure that everything works fine, then I'd perform a customization.

LED flickers under Shutdown situation. You'll need to read the 1Byte Shutdown address in order to figure out what the error means.

Thank you.

2018-09-07 09:47:07
Will Son
2018-09-14 20:29:19 Italo

Feedback: I was not setting torque enable register and that was the issue. Dynamixel moved correctly after that 

2018-09-14 20:29:19
Italo
Reply
웹에디터 시작 웹 에디터 끝