...
POST No. 2406966
XL430-W250-T - Problems with three of them...
2018-09-12 09:15:38 kurteck

My guess is I know the answer.  But thought I would ask to see if maybe I am over looking something.


Been doing lots of experimenting lately trying to changes some of the OpenCM9.04 core code.  And I was having some issues with my new FIFO non blocking Serial code to talk to some of the servos.  I finally figured out that it was probably the servos.


I have 6 of these newer servos setup like two hexapod legs... One leg worked and the other leg, none of the servos now work.

I tried each of them connected separately and none of them work, and no other servo will communicate when any of these are plugged in.


I also noticed on the OpenCM485 expansion board.  If I plug any of these servos in, the RXC light stays on.  So I think the servos are holding the TX line probably to ground.  Not sure what happened.  Maybe somehow the 12v went to the DXL line? 


These servos came from Trossen probably back in February to help prototype code for hexapod. 


Any suggestions on recovering the servos?   My guess is that I need to do an RMA request and have them repaired.  Or should I just order new ones?


Thanks

2018-09-12 09:15:38
Kurt
2018-09-12 10:50:07 Will Son

Hi Kurt,


The RX led supposed to be flicker when there's low signal on either TTL or RS-485 RX lines(as they are pulled up with 5V)

These two signals are tied with AND gate to produce low signal when one of them is low.


If the LED is always turned on, please try firmware recovery on those servos, and see if they are detected with R+Manager 2.0.

If above method fails, please request repair service as communication ICs could be damaged.


Thank you.

2018-09-12 10:50:07
Will Son
2018-09-12 23:01:17 Kurt

Thanks Will,


I sort of assumed the LED on was holding pin to GND.   I had looked at the schematic: http://support.robotis.com/en/baggage_files/opencm/schematic1___opencm_485exp.pdf

But I like your extract from it where you don't have to scroll around.


I tried R+Manager 2.0 using OpenCM9.04 board and all three failed to be seen.  I tried with another one (off of the other leg) and it was able to recover the firmware on it... (Not that it needed to).

I also tried having R+Manager detect it using a USB2AX board and again it could not communicate with those three servos, but could with another...


So will request service...  May still still want to order a couple as I know that repair can take awhile.


Thanks again!



comment
2018-09-13 09:55:13 Will Son
Thank you, Kurt.
Simple repair service will be performed at ROBOTIS USA branch so you might get it back earlier than you might expected :)
2018-09-13 09:55:13
Will Son
2018-09-13 10:50:25 Kurt
Thanks Will,
I am doing some of both, that is I created an RMA Request form and I am now waiting for response with RMA number.

I also ordered 2 new ones today, to continue experimenting. The only time I had a servo serviced (MX-12w), it took something like 6 weeks.
2018-09-13 10:50:25
Kurt
2018-09-14 17:25:25 Will Son
Whoa... that was way too long.
I have no idea what happened at that time, but 6 week is definitely not good.
This time it should be much faster than before unless US branch is out of replacement parts.
Thanks!
2018-09-14 17:25:25
Will Son
2018-09-12 23:01:17
Kurt
Reply
웹에디터 시작 웹 에디터 끝