...
POST No. 2406996
dynamixel XL320, OpenCM9.04, roboplus 2
2018-10-10 18:37:36 dheerajtippani

Hi!

i hope someone here can help me with my problem

Description:
XL320 dynamixel servo is not responding to the Opencm9.04 examples and roboplus2 is not working.

Hardware concerned:

OpenCM9.04 IDE—to–examples—to–laptop—to—(USB)—to—OpenCM9.04—to—(cable)—to—XL320.

Software concerned:
Open CM 9.04 latest updated IDE.
OS: Windows 7 ultimate SP1 64 bit.

Troubleshooting steps already taken:
tried all examples Opencm ide. examples like “wheel mode1 and 2”, “bps changing”, “speed&position”, etc are not moving anything in XL320. Those examples are not working.

tried to install roboplus2 in another laptop with Windows 10 OS. didn’t work. not even the examples.

installed Open cm9.04 board into Arduino IDE and tried with examples in Arduino. nothing works

Additional information:
please help me. stuck here for a long time. I want to make a robotic arm with AX12 servos and one xl320.

Thank you so much in advance for your help!

2018-10-10 18:37:36
dheeraj
2018-10-11 02:29:41 Kurt

Normal caveat, that someone from Robotis like  @Will Son can answer this a lot better than I can.


First suggestion: Don't use OpenCM9.04 IDE, but instead go to Arduino, as Robotis is switching everything over to Arduino.

Instructions are up at: http://emanual.robotis.com/docs/en/parts/controller/opencm904/#arduino-ide


How is the XL320 powered?  Do you have external power, the OpenCM9.04 shows a few examples on how to hook up power in the section: http://emanual.robotis.com/docs/en/parts/controller/opencm904/#connecting-power


R Plus Manger 2: try loading this up: http://emanual.robotis.com/docs/en/software/rplus2/manager/

Choose the Robotis Mini as the product, when asked.

Then  plug in you OpenCM9.04 board and use the Firmware recovery  Choose the OpenCM 9.04 board and follow the instructions choose your serial port, press down the user button, and hit the reset button,  You should then hopefully get it to the point it says what version of stuff it found and then hopefully it put on the default firmware...


Now go to Update and Test section again choose the correct serial port, do a scan which it should find your OpenCM board...  I think by default the Firmware for OpenCM is setup to properly detect servos on the actual DXL connectons on the board and probably at the right baud rate for the XL320.  If not you can change these settings once it shows the Control table for the OpenCM board

That is I believe it defaults;

Address 12 baud rate buss: 1MBS value of 3

Address 16 default XL320 (Serial1 - port connected on board) value 0...  The value 1 is if you are using the OpenCM RS485 expansion board.


Assuming the above is working, does it see the XL320 servos?   If not and you have proper power, you might try firmware recovery on the servo as well.  Same steps as the OpenCM recovery, that is you choose to XL servo recover instead of OpenCM... and only have one plugged in, and when prompted to unpower the servo or the like, I typically unplug it and plug it back in.  Hopefully it then sees the servo and then you can follow the steps to update the firmware on the servo


Mixing AX servos with XL320 servos.  AX servos use Protocol 1, where as XL320 servos run using Protocol 2.  So any software written needs to be handle both protocols.


There are probably other hints I am missing, but hopefully this will get you up and running.


Good Luck








2018-10-11 02:29:41
Kurt
2018-10-15 13:26:22 Will Son

Hello,


XL-320 on OpenCM9.04 requires 7.4V power input. 

You can use two sets of LB-041 and LBB-041.

If possible, please use Arduino IDE instead of OpenCM IDE as Kurt mentioned in the above reply.

OpenCM IDE will not be supported and updated anymore.


========Edited=======

If you are going to use LB-041 battery, please use LBS-40 Battery Sockets from below manual.

http://emanual.robotis.com/docs/en/parts/controller/opencm904/#connecting-power


Thank you.

2018-10-15 13:26:22
Will Son
Reply
웹에디터 시작 웹 에디터 끝