...
POST No. 2407084
Driving XL-430-W250T with OpenCM 9.04 - What am I doing wrong?
2018-11-07 05:54:58 TheBigSasha

This is my first time using any Dynamixel products, so I apologize in advance for my inexperience.


I am trying to drive a Dynamixel servo with the OpenCM 9.04c board, here is what I've tried:


Hardware:

Method 1:

Solder cable together to connect XL-430 to the XL-320 connector on the OpenCM board, power via 12v 3a supply to ++ and -- pins on the OpenCM board


Method 2:

Connect power directly to XL-430, data to TTL pin on OpenCM 9.04. (GND and + from PSU connected to GND and + on both the OPENCM and directly to the motor)


Method 3:

Connect power to XL and board as in method 2, data to data pin of header 1 on the board.


Software:

The board wouldn't detect until I refreshed the firmware using R+ Manager 2.0, when the board detects properly

Motors have not yet ever been detected by the software regardless of anything I've tried.

2018-11-07 05:54:58
Sasha A
2018-11-07 11:29:38 Kurt

@Will Son - will probably give you a much more detailed answer, but I thought I would throw out a few things, in the hope something might help.


 Hard to say, without more information, like how are you trying to detect the servos.  


But here are a few things I would suggest trying.


1) use R+ Manager 2.0 - load the program and choose Robotis Mini - From there choose Firmware Recovery on the OpenCM9.04

2) After the firmware recovery on the OpenCM go to Update and Test

3) When it is showing the Control table for OpenCM9.04 check and change the values for

a) 16 - Dynamixel Channel - Set to 0 (default) again assumming you don't have a Open CM485 expansion.

b) 12 - Baud Rate (Bus) - Set to 1 (57600) as this is the default for XL430... Servo


4)  I close out the test window and click on Home  button (F1) And choose Dynamixel X, with this only have one new servo plugged in as by default they all default to id #1.

5)  Now try an Update and Test - Hopefully the one servo will show up and you can play with it's settings, like change the ID and then you should be able to plug in another servo and you can hit the refresh button near upper right of window and hopefully it will find both servos...


Note: If you decide to change the Baud rate of the servo (I typically run at 1mbs), then you will need to go back and choose the parameters for the OpenCM and change the Bus baud rate and then do a refresh again...


comment
2018-11-11 06:54:47 Sasha A
Thanks for the tips!

I have done all of step 1 previously, but I haven't done step 4. I'll check it and get back to you.
2018-11-11 06:54:47
Sasha A
2018-11-11 07:13:39 Sasha A
Step 1 went as normal, but when I switched to Dynamixel X Series, the scan found no motors.

I have the motor connected to +- from the power supply, same pins as the board is connected to.
I have signal going to the TTL pin on the board

One of my motors in this setup flashes its red led once when plugged in, the other has the red led continuously flashing.

The software does successfully interface with the board, it just doesn't see the motors.
2018-11-11 07:13:39
Sasha A
2018-11-12 10:11:47 Will Son
When searching connected Dynamixel on OpenCM9.04, you should not choose a specific Dynamixel as target product, but have to select "OpenCM9.04".
Please refer to below image that I always select OpenCM9.04 as a Product on the top right corner.
"While searching is in progress, wait until the search ends."
2018-11-12 10:11:47
Will Son
2018-11-12 23:31:16 Kurt
Again you need to make sure that the Dynamixel channel and baud rate are set. Only insert one dynamixel and do the search.

I actually did this yesterday again, although I am using a board with the OpenCM485 expansion.

I had three of these servos that came back from an RMA (about 7.5 weeks) and they all came back as ID #1 and baud 57600 (i.e. back to factory defaults). So did the process to plug in one, do the search, Set their ID, then set their baud. Then plug in the next one repeat... Finally then go back to the OpenCM boards settings and change the BAUD rate(Bus) to 1000000 and then do another search and all three showed up...
2018-11-12 23:31:16
Kurt
2018-11-07 11:29:38
Kurt
2018-11-07 11:36:11 Will Son

Hi Sasha,


All your methods looks fine.

In order to detect Dynamixel from OpenCM9.04, you need to perform firmware recovery for OpenCM9.04 first.

It is because R+Manager 2.0 will not be able to detect OpenCM9.04 with a custom firmware.

Once you are done with OpenCM9.04 firmware recovery, you can connect XL-430 to Dynamixel TTL 3PIN on OpenCM9.04 and turn on the power.

Then go to R+Manager 2.0 and select "OpenCM9.04" and perform "Update & Test".

While searching is in progress, wait until the search ends.

When search ends, you'll be able to see your XL-430 is also detected and can be controlled.


 
 


2018-11-07 11:36:11
Will Son
Reply
웹에디터 시작 웹 에디터 끝