...
POST No. 2407284
[TxRxResult] Incorrect status packet!
2019-02-04 09:23:50 Jasmin

The problem that I am having now for the second time is the following where I get this error message: [TxRxResult] Incorrect status packet!
The thing that is weird about that is that I recieved this message suddenly this means that 30 seconds before the message motor worked totally fine and I didnt change the code and then when I tried to restart the program I get this error message. So this means that the baudrate and the Id should definitifely be correct. And after I exchanged the controller with another one, the program worked fine again. For both controllers I used exactly the same code.
The code that I am using is some specific for the game that I am working on. So if you want to have a look at the code I will send it to you. But I dont think the problem lies in the software.

And now for the setup:
-motor: mx-12W
- controllers: first RS 232, after U2D2 (both broke)
- a raspberry Pi 3 model B+ (powered by 5V)
- 3Pin Power Hub
- power supply for the motor: 12V/1.5A

The connections of the whole setup is: raspberry Pi -> Controller -> 3Pin Power Hub -> Dynamixel -> my mechanism
2019-02-04 09:23:50
Jasmin
2019-02-07 14:33:57 Will Son

Hi,


I'm sorry for the late reply due to Lunar New Year holiday.

Are you using the latest version of DynamixelSDK?

Please let me know if you modified the library or copied necessary part of the library because there's a byte stuffing that detects redundancy in the status packet and sometimes this essential code is not properly implemented.

2019-02-07 14:33:57
willson
Reply
웹에디터 시작 웹 에디터 끝