...
POST No. 2407535
PWM not possible with XL430-W250-T?
2019-08-13 13:52:02 ralph123

Hi there,


I am trying to operate the XL430-W250-T servo in PWM mode but fail again and again.


Here is my setup: mac, OpenCM 9.04, OpenCM 485 Expansion Board.

I don't have and want to use a U2D2.


I tried several different ways of setting PWM mode but in (almost) any instance, the board got completely unresponsive and I had to go into recovery mode.

On Github it was suggested that I use Dynamixel Wizard 2.0 but this requires U2D2. At least I cannot find my servos with that software.


I CAN interact, ping, etc. the servos via the `p_monitor` example and also in normal position control mode. But I want to use PWM.

I tried with workbench and classical api.

Please someone help me with a minimal example script to go into PWM operation mode and do a basic control in the `loop()`.

Since I do not get email confirmation after making my account here (another great fail from ROBOTIS), I might not be able to answer with my own account directly under this.



I attached my current stab at it. I use `writeRegister` directly now to bypass any tests that might hinder setting the mode. I once got it to activate the mode and to receive and send data, but neither would do anything so I doubt it was even in PWM.

Uploading this code to the board will currently: make the USB port dissapear in Arduino IDE and persist like this until I go into recovery mode.


Please help.





2019-08-13 13:52:02
ralph123
2019-08-14 09:52:16 Will Son

Hi,


I apologize for missing the email notification feature.

We're currently looking for a solution.

If you don't mind, you can also post your issue on the Robotsource > Question so that you can get an email notice.

https://community.robotsource.org/c/question 


For the simple PWM example, have you tried Dynamixel2Arduino example?

If you haven't, please try it first by installing the Dynamixel2Arduino library.

http://emanual.robotis.com/docs/en/parts/controller/opencm904/#library-api 


Thank you.

2019-08-14 09:52:16
willson
2019-08-14 12:49:19 ralph
Wow that worked, thank you so much willson!
How come there are three libraries where certain modes only work in one of them?
2019-08-14 12:49:19
ralph123
2019-08-16 10:23:51 Will Son

Hi,


There are different purpose for each library, and workbench is mostly intended for ROS compatibility.

As Arduino libraries are open source and being developed based on collaborative work, there could be some unintended issues.

I've reported the Workbench library bug to development team and I think it'll be fixed in the next update.

Thank you very much for your feedback  :)

comment
2019-08-16 12:38:27 ralph123
Thank you willson, much appreciated!
2019-08-16 12:38:27
ralph123
2019-08-16 10:23:51
willson
Reply
웹에디터 시작 웹 에디터 끝