...
POST No. 2407578
OP2-FSR Set Connection Problem with U2D2
2019-09-05 07:29:52 pyuaaa1

Hi,


We have a pair of ROBOTIS OP2-FSR Set (http://www.robotis.us/robotis-op2-fsr-set/) , and we have problems with the software communication. We connected it to the TTL port on a U2D2 and tried the following things.


Firstly we tried to connect with one of the feet using R+ Manager (v2.2.17). It only worked once, and after that no matter how we changed the settings or kept the same settings, it couldn't be connected again. In the only successful connection, we noted the ID of that foot was 111, and Baud rate was 1Mbps.


Then we used the Dynamixel-SDK in Matlab. The connection was successful for the first few times (we could access to RAM address 34 (0X22) and read normal FSR_Central_X data). But after that, the device couldn't be found again. It always showed the following information:


Succeeded to open the port!

Succeeded to change the baudrate!

[TxRxResult] There is no status packet!

[ID:111] PresPos:000


We also tried the SDK in python and c++ in linux ubuntu, but it didn't work.


All the above trials are done by connecting one FSR foot on a U2D2, supplied by 11.1V battery.


Is there anything we can do?


Thank you!

2019-09-05 07:29:52
pyuaaa1
2019-09-05 15:37:54 Will Son

Hi,


If you are experiencing problem with using FSR sensor, I'd recommend firmware recovery with DYNAMIXEL Wizard in RoboPlus software as shown below.

Since FSR support Protocol 1.0, it might be easier for you to use DYNAMIXEL Wizard. (R+Manager v2.2.17 mainly supports Protocol 2.0)


You can use Firmware Recovery button to recover each FSR at a time.


 

Once recovery is completed, you can connect to each FSR and set the proper ID(Right : 111, Left : 112)

The baudrate should be identical to other DYNAMIXEL which will be 1,000,000bps(1Mbps)


For more information about DYNAMIXEL Wizard, please refer to eManual.

http://emanual.robotis.com/docs/en/software/rplus1/dynamixel_wizard/


Thank you.

comment
2019-09-06 02:17:00 pyuaaa1
Thank you for your reply! However, the firmware recovery didn't work.

I followed the steps in eManual. When I did the step 5, "Turn off the power of Dynamixel and then turn it back on.", it didn't detect anything. At the moment I turn the power back on, the red power light on the FSR foot was always on, which I thought is not normal.

In other cases, when I connected the FSR foot with 11.1V power, the red power light flashed normally. It was on for 0.5 second and off.

I also tried the firmware recovery on other motors I have (XL320, XH430 etc), and it worked. So I believe the steps I took were correct.
2019-09-06 02:17:00
pyuaaa1
2019-09-05 15:37:54
willson
2019-09-10 17:16:14 rjtp5670

Hi, 


After step 5 in which you turns DYNAMIXEL's power back on, the LED on FSR emits the solid red is normal; you are on Firmware Recovery.
 

Aside from the case as mentioned above, LED on FSR should blink one time. 


You may want to try using an another PC then proceed to the same step you did.


If the same issue happens again, please send the part to ROBOTIS, so that we can investigate the root cause


Please refer to the associated link below. 

http://en.robotis.com/model/page.php?co_id=repaircenter 


Thank you,







 


Drop here!
comment
2019-09-12 02:49:04 pyuaaa1
Thank you for your reply!

We tried the firmware recovery on 2 different computers with Win10. The same problem was still there.

We bought your product in the US. We have already referred to the repair center on the US website, and we have filled the RMA form (a google doc) on September 6 local time. Hope to get your response soon.
2019-09-12 02:49:04
pyuaaa1
2019-09-10 17:16:14
davidpark
Reply
웹에디터 시작 웹 에디터 끝