...
POST No. 2407615
Dynamixel XL 430- W 250 not detecting using R+ manager 2.0
2019-10-05 06:43:16 kkk123

Hi


I am using Open CM 9.04 + EXP board and XL 430 W 250 as per below pic.  I used R+ Manager 2.0 to recover the firmware of OpenCM 9.04 and it was successful. But for "Update & Test" servo is not detecting. Also I tried with Arduino position_mode sketch, which is not giving result.


If I connect same servo to U2D2, I can successfully operate with Wizard 2.0


I am not sure why OpenCM 9.04 controller is not working.


Thanks
 

2019-10-05 06:43:16
kkk123
2019-10-08 05:21:11 KKK

hi


I  was now able to detect the Dynamixel with OpenCM 9.04i R+ Manager 2.0 and to see control tables.  


However I was more interested in programming Dynamixel servo through OpenCM 9.04 and Arduino IDE. I tried using "Dynamixel2Arduino" Library and some of the examples such as position_mode or ping, bit couldn't see the effect with servo. I am not sure if I am missing anything with above mentioned setup.


Thanks

2019-10-08 05:21:11
kkk123
2019-10-08 05:37:26 KKK

In My R+ Manager 2.0 I am not able  to see XL430 . Is it only communication issue with Dynamixel?



 

2019-10-08 05:37:26
kkk123
2019-10-08 23:26:17 Kurt Eckhardt
@wilson or others from Robotis can probably answer this better than I can, but I think you don't have the proper channel selected.
Looks like in your last picture you Baud Rate BUS set to 3 which I believe is correct (1MBS default for servo).

But The Dynamixel Channel value (16) I believe I am seeing as 0 which if I remember correctly is the OpenCM 9,.04 servos on main connectors (XL-320) servos which is on Serial1

You need to change that to the Open CM 485 expansion board setting.  (Serial3), which is the other setting (1 or 3? ) I would have to setup to see the actual value.  But change it to the other value it allows, and then do a rescan...
2019-10-08 23:26:17
kurteck
2019-10-09 05:01:14 KKK

Thanks Kurteck for reply.


I have tired with Baud rate change and Dynamixle Channel value change as well.  I  changed those to 57600 and Open CM 485 EXP respectively through R+ Manager 3.0. However still I am yet to get get any communication to Dynamixel.  Not sure what I am missing here. Same Dynamixel is detecting

/moving using U2D2.

2019-10-09 05:01:14
kkk123
2019-10-11 17:24:07 Will Son

Hi,


Please see below video clip and detail settings are described under the video.

https://youtu.be/FgjGq16-9Dc


You need to match the Baud Rate(BUS) of OpenCM9.04 and Baud Rate of XL430-W250 before detecting DYNAMIXEL via OpenCM9.04 + EXP board.


Thank you.

2019-10-11 17:24:07
willson
2019-10-15 06:07:09 KKK

Thanks for your help 

Finally I was successful in moving servo using Arduino. The issue is R_Manager 2.0 doesn’t  SAVE baud rate if certain sequence is not followed.

 

Here is the sequence I followed:

 

1.       Update firmware through  Open CM 9.04

2.       Reconnect USB to COM again from Open CM 9.04

3.       Open “Update & Test” and change baud rate  to 1 (57600) and Dynamixel  Channel to 3 and press SAVE

4.       Restart EXP board and connect again USB of OpenCM 9.04

5.       Open “Update and Test” but baud rate again went back to 3. So change baud rate in detected XL430 to 1 and then change baud rate in OpenCM 9.04 to 1 as well and press SAVE after each change.

 

2019-10-15 06:07:09
kkk123
Reply
웹에디터 시작 웹 에디터 끝