...
POST No. 2407650
There is a problem with operation OpenCR/CM9.04 with Arduino.
2019-11-06 11:24:08 Allie

https://raw.githubusercontent.com/ROBOTIS-GIT/OpenCR/master/arduino/opencr_release/package_opencr_index.json


Can't Chinese users use this connection to download OpenCR/CM9.04 to the development board manager? 


When I find the page in figure 2, the URL corresponds to the following link: 


https://github.com/ROBOTIS-GIT/OpenCR/blob/master/arduino/opencr_release/package_opencr_index.json


I tried to add this connection to the preference, and the board manager still reported errors and more errors. 


Please take a closer look at my question. My client is in a hurry. I have been asking for nearly a week and have not received a valuable response so far. 


THX.

2019-11-06 11:24:08
Allie
2019-11-06 14:56:34 Will Son

Hi,


It looks like the json file is corrupted as the error message shows "parsing error occured".

If possible, reinstall the Arduino IDE and try again, or you may manually install the packages by creating folders and download required files and extract them into the folder.

Below instruction is written based on Windows.

  1. 1. Go to Arduino installed folder
    C:UsersAppDataLocalArduino15packages
  2. 2. Create "OpenCR" folder and move into the OpenCR folder. ("OpenCM904" for OpenCM9.04 board)
    C:UsersAppDataLocalArduino15packagesOpenCR
  3. 3. Create "hardware" and "tools" folder.
  4. 4. Download below file and extract until "opencr" folder appears. Change folder name from "opencr" to "1.4.13", and copy the folder. (change to "1.4.2" for OpenCM9.04 board)
    OpenCR : https://github.com/ROBOTIS-GIT/OpenCR/releases/download/1.4.13/opencr.tar.bz2
    OpenCM9.04 : https://github.com/ROBOTIS-GIT/OpenCM9.04/releases/download/1.4.2/opencm9.04_core_1.4.2.tar.bz2
  5. 5. Move into the "hardware" folder, and create "OpenCR" folder. Then paste the extracted "1.4.13" folder from step 4. (create "OpenCM904" for OpenCM9.04 board)
    C:UsersAppDataLocalArduino15packagesOpenCRhardwareOpenCR1.4.13
  6. 6. There should be [bootloaders], [cores], [libraries], [variants] folders and 4 text files inside of the 1.4.13 folder.
  7. 7. Now move into the tools folder and create "opencr_gcc" folder. (create "opencm_gcc" for OpenCM9.04 board)
    C:UsersAppDataLocalArduino15packagesOpenCRtoolsopencr_gcc
  8. 8. Download below file and extract until "gcc-arm-none-eabi-5_4-2016q2-20160622-win32" folder appears. Change the folder name from "gcc-arm-none-eabi-5_4-2016q2-20160622-win32" to "5.4.0-2016q2".
    OpenCR & OpenCM9.04 : https://github.com/ROBOTIS-GIT/OpenCR/releases/download/arduino/gcc-arm-none-eabi-5_4-2016q2-20160622-win32.tar.bz2
  9. 9. Copy the "5.4.0-2016q2" folder into the "opencr_gcc" folder from step 7. (copy into "opencm_gcc" for OpenCM9.04 board)
    C:UsersAppDataLocalArduino15packagesOpenCRtoolsopencr_gcc5.4.0-2016q2
  10. 10. Move back to "tools" folder
    C:UsersAppDataLocalArduino15packagesOpenCRtools
  11. 11. Create "opencr_tools" folder and download below file. (create "opencm_tools" for OpenCM9.04 board)
    OpenCR : https://github.com/ROBOTIS-GIT/OpenCR/releases/download/1.0.0/opencr_tools_1.0.0.tar.bz2
    OpenCM9.04 : https://github.com/ROBOTIS-GIT/OpenCM9.04/releases/download/tools/opencm_tools_0.0.2.tar.bz2
  12. 12. Extract until "opencr_tools_1.0.0" folder appears. Then change the folder name from "opencr_tools_1.0.0" to "1.0.0" (change "0.0.2" for OpenCM9.04 board)
  13. 13. Copy the "1.0.0" folder into the "opencr_tools" folder from step 11. (copy "0.0.2" folder into the "opencm_tools" for OpenCM9.04)
    C:UsersAppDataLocalArduino15packagesOpenCRtoolsopencr_tools1.0.0
This should allow user to use the OpenCR / OpenCM9.04 on Windows Arduino IDE.
Thank you.
2019-11-06 14:56:34
willson
2019-11-06 18:10:59 Allie

Thank you very much. Now OpenCR can be used normally.

But CM9.04 still doesn't work.

Is it possible that there are two reasons:

1.OpenCR and 9.04 cannot exist in the development board manager at the same time;

2.Look at the figure. Relative to OpenCR , is 9.04 missing the "bootloaders" folder?

Or there are other reasons why I can't add 9.04.

Thank you again for your careful guidance and help.
 

2019-11-06 18:10:59
Allie
2019-11-11 14:02:02 Will Son

Hi,


OpenCM9.04 does not need bootloader as it is already downloaded to the board during manufacturing process.

However, the files and folders in opencm9.04_release have to be moved into the 1.4.2 folder.

If you take a look at OpenCR folders, bootloaders, cores, libraries, variants folders are in the 1.4.13 folder, so you need to match this structure to OpenCM9.04 as well.

Thank you.

2019-11-11 14:02:02
willson
2019-11-11 14:33:51 Allie

I've moved the files and folders in opencm9.04_release  into the 1.4.2 folder. 

But I still can't find 9.04 in development board manager. 

If you can, please email me the files I need to add and the location of the corresponding files. 

268074499@qq.com

Thx.
 

2019-11-11 14:33:51
Allie
2019-11-11 14:58:25 Allie

Besides, I'd like to ask if 9.04 can control XL430-W250-T by R+ manager 2.0.

comment
2019-11-13 09:59:55 willson
Yes, it is recommended to use OpenCM485EXP board in order to control the XL430-W250-T with OpenCM9.04.
Please see below example video.
https://youtu.be/FgjGq16-9Dc
2019-11-13 09:59:55
willson
2019-11-11 14:58:25
Allie
2019-11-12 11:11:15 Will Son

Hi,


Have you also received opencm_gcc and opencm_tools?

 


Also, it seems like you are using extracted folder instead of the Arduino15 folder in the C drive where preferences and settings are saved.

Please find the Arduino15 folder in AppData > Local directory (Folders may be hidden) and install OpenCR and OpenCM9.04 in it.


 


Thank you.

2019-11-12 11:11:15
willson
Reply
웹에디터 시작 웹 에디터 끝