...
POST No. 2407739
XL-320 DYNAMIXEL and OpenCM controller - DYNAMIXEL not found
2020-02-09 18:04:36 314735572

Hello,
I bought an OpenCM controller, XL-320 DYNAMIXELS and USB Downloader LN-101 and I have a problem with these.
When I connect a DYNAMIXEL to the controller,  the controller to power source and to my PC via the USB micro-B cable, and choose an example from the ROBOTIS_OpenCM application (such as Dynamixel Easy  -> b_setID) it works, and the motor moves.

However, when I connect the USB Downloader LN-101 and use the Dynamixel Wizard in the RoboPlus application, no DYNAMIXEL is found. I tried it with few DYNAMIXELS and it didn't work for either of them.
Do you know what may be the problem? Do I do something wrong?

I'll be glad if you can help me. 


Thank you!
Tifferet 

2020-02-09 18:04:36
314735572
2020-02-10 12:55:24 Will Son

Hi,


Thank you for your inquiry.


First of all, please note that OpenCM IDE is deprecated and not supported anymore.

Please use Arduino IDE for the latest support.

http://emanual.robotis.com/docs/en/parts/controller/opencm904/#arduino-ide 


In order to detect DYNAMIXEL from ROBOTIS software via OpenCM9.04, please use USB port with the factory default OpenCM9.04 firmware that can be recovered from R+Manager 2.0.


FYI, XL-320 properly operates with 7.4V power source(XL-320 Specifications).


Thank you.

2020-02-10 12:55:24
willson
2020-02-12 22:17:57 Tifferet Nevo

Hi,


Thank you for your answer.

I use 7.4V power source..


I tried to recover the DYNAMIXEL according to the explanation you referred me to, but the recover failed.

After I choose the XL-320 DYNAMIXEL, the port recognized:

The port type is "Recently connected devices" and the port number is "USB Serial Port (1.0) COM6".

I click NEXT and the massege "The device is connected" Appears then disappears.

After that I get to the attached screen, and I can't click NEXT, even after I un-plug and re-plug the Dynamixel cable


Do you know what may be the reason?


Thank you!

Tifferet

2020-02-12 22:17:57
314735572
2020-02-17 09:24:43 Will Son

Hi,


It looks like your R+Manager 2.0 is outdated.

I connected USB + OpenCM9.04(Firmware recovered) + XL-320 and searched from R+Manager 2.0 as below.


 

Please update R+Manager 2.0 to the latest version(v2.2.19) and try again.

Thank you.

2020-02-17 09:24:43
willson
2020-02-18 18:09:07 Tifferet Nevo

Hi,


I think my problam was that I didn't recovere the OpenCM9.04 Firmware after I used it.

Now I did it and it works.


Thank you!

2020-02-18 18:09:07
314735572
Reply
웹에디터 시작 웹 에디터 끝