...
POST No. 2407742
How can I connect 4 DYNAMIXEL XL430-W250T with OpenCr 1.0(like Turtlebbot3 monster)?
2020-02-14 20:17:53 Dhaour9x
Hi everyone, I am currently writing my master thesis in the field of autonomous systems based on the Robot Operating System (ROS) I have Turtlebot3 burger as a base and I want to build turtlebot3 burger with 4 DYNAMIXEL XL430-W250T, but I didn't find any assembly instructions for it. I also tried to connect the rear servo motors to the front motors, which I connected with OpenCr (TTL), then I updated the Opencr frimware via arduino (File->Example-> turtlebot3->turtlebot3_friends-> turtlrbot3_monster)and tested with PUSH SW 1 and PUSH SW 2, but unfortunately the motors did not rotate. If I update the Opencr frimware via arduino (File->Example-> turtlebot3->turtlebot3_waffle-> turtlrbot3_core)update, the test works with PUSH SW1 and PUSH SW 2 and Only the front engines rotate. I would like to ask you if there is any help material to help me with the hardware and OpenCr frimware update (turtlebot3 burger with 4 DYNAMIXEL XL430-W250T) configuration.
2020-02-14 20:17:53
Dhaour9x
2020-02-17 09:58:24 Will Son

Hi,


First of all, TurtleBot3 friends does not support ROS.

In order to use the Arduino example, you should first set the correct ID and baudrate as below.

If you have U2D2, you can connect DYNAMIXEL to change ID and buadrate, or download Arduino OpenCR examples > 08. DynamixelWorkbench > p_Monitor to OpenCR to change ID and baudrate.

#define DXL_LEFT_REAR_ID                1       // ID of left rear motor
#define DXL_RIGHT_REAR_ID               2       // ID of right rear motor
#define DXL_LEFT_FRONT_ID               3       // ID of left front motor
#define DXL_RIGHT_FRONT_ID              4       // ID of right front motor
#define BAUDRATE                        1000000 // baud rate of Dynamixel

https://github.com/ROBOTIS-GIT/OpenCR/blob/master/arduino/opencr_arduino/opencr/libraries/turtlebot3/examples/turtlebot3_friends/turtlebot3_monster/turtlebot3_monster_motor_driver.h#L47 


FYI, the DYNAMIXEL test buttons are designed only for the burger and waffle.

Thank you.

2020-02-17 09:58:24
willson
2020-02-20 03:59:45 Riadh

Hi,

Thank you very much for feedback.

Your solution doesn't work !

I restart opencr with turtlebot3 waffle via Arduino, then I have tried to control the TB3 (roslaunch turtlebot3_bringup turtlebot3_roboter.launch) and (rosrun turtlebot3_teleop turtlebot3_teleop_key). But does not work.




I just want to reconfigure TB3. Which steps should I take to get TB3 work again.


Thank you.

2020-02-20 03:59:45
Dhaour9x
Reply
웹에디터 시작 웹 에디터 끝