...
POST No. 2407931
360 Laser Distance Sensor LDS-01 issiue
2020-08-10 17:15:28 Ivan4815162342
Hello,

I am working with 360 LDS-01 lidar and it has worked fine so far. I don't know why, but at some point I only get zero values in the range array and not a single point in RVIZ. After that, I noticed that one of the wires (red on the edge with the inscription 5V) was cut off. I soldered it but it didn't help. Do you know the reasons for my problem and how to solve it?
2020-08-10 17:15:28
Ivan4815162342
2020-08-11 13:26:29 Will Son

Hi,


Without actually evaluating the module, it is difficult what causes the issue, but if the sensor was not returning any useful value but zeros, I'd assume that the sensor is out of order.

Thank you.

2020-08-11 13:26:29
willson
2020-08-11 20:54:41 Ivan

Thank you for your response. I understand that is difficult to find out what causes the issue without actually lidar. But maybe you heard about the same issuies and can predict the most probability reasons for sensor is out of order? Also I want to notice that zero values return only in range array. For example intensities array has not zero values.

2020-08-11 20:54:41
Ivan4815162342
2020-08-12 11:21:14 Will Son

Hi,


This is my first time to hear that the Lidar fails to send distance array data.

I'm clueless why intensity only works while distance is failing.

Are you reading the raw array data directly from the sensor?

2020-08-12 11:21:14
willson
2020-08-13 19:41:35 Ivan
Yes, I do it with help of rostopic info /scan
2020-08-13 19:41:35
Ivan4815162342
Reply
웹에디터 시작 웹 에디터 끝