...
POST No. 2407947
facing issues with XM430-W350-T
2020-09-20 17:15:24 Mohana

Hi,


I'm using four dynamixel XM430-W350-T controlled by arduino along with the Dynamixel Shield using Dynamixel2Arduino library. The problem is only one of the four motors is responding and other three seems to be dead, only that led glows once when powered up. I tried almost all the basic examples in the library but nothing works. When I try 'scan_dynamixel', I get results about only one motor. When I try factory reset and reboot, I get failed as output. 


Is there any way to bring back those motors alive? (motors are not new)


Thank you in advance!


Regards,

Mohana

2020-09-20 17:15:24
Mohana
2020-09-22 13:37:28 Susan Mackay

Have you altered the IDs of the servos. When you get them the ID is pre-set to '1' (at least for my servos which are slightly different model to yours) and you need to program them all with a unique number.

Also, are they servos in a chain? And is it the first servo in the chain that is responding

Try connecting each servo one at a time to see if it is working or not. If they do all have the same ID then connecting one at a time will still work - plus it will also let you reprogram the ID for that servo to a unique (for your set of servos) number.

Susan

2020-09-22 13:37:28
aussiesusan
2020-09-23 17:52:36 Mohana Durga Balasubramanian

Hi Susan,


I tried connecting each servo separately and also in a chain, but in both cases the result is same i.e., no response at all. (only servo with ID set as 1 is working) 

As I already mentioned these servos are not new, so they have already been configured to some unique IDs. 

When I run 'Scan Dynamixel' only servo with ID as 1 is shown in the output, other servos are not found. 


I have attached the screenshot where I have uploaded 'scan_dynamixel' example and I have connected three servos into the Dynamixel Shield, but only with ID 1 is being scanned. (however, all connected servos' led glows when powered up)


So, I'm puzzled right now, whether there may be a possibility where all my other servos could be dead.

Please let me know if I could fix this somehow.   

2020-09-23 17:52:36
Mohana
2020-09-24 09:25:53 Will Son

Hi Mohana,


Thank you for attaching the captured screen.

According to the Model number displayed in the terminal, you might have recovered a wrong firmware for your XM430-W350 since Model Number 1030 represents XM430-W210.

Recovering with a wrong firmware may cause hardware damage so please use the correct firmware.

Also, if you are not sure about the DYNAMIXEL configuration, I'd recommend to recover the firmware via DYNAMIXEL Wizard 2.0 with correct firmware then try modifying other details such as ID and baudrate.

When recovering the firmware, you should connect only one DYNAMIXEL at a time.

Thank you.

2020-09-24 09:25:53
willson
Reply
웹에디터 시작 웹 에디터 끝