...
POST No. 2407958
Dynamixel MX-64 Problems
2020-10-09 06:26:48 964415913

Hi. I made one sand robot with four MX-64. All of servos can be detected and runned by dynamixel wizard. But when I runned the dynamixel example in Robotis, it failed. I The baud rate is right. I have tested 57600, 1000000 and 2000000 ,and they didn't work. 


Interesting thing is I have another MX-64. The same code worked on this servo and failed on other four. So I tried to recover them. When I connected the power to recover each one of four MX-64, nothing happened. I tested a lot of libraries and codes. Only few codes can still work. 


So I remember the first time this problem happened. It could walk on the sand well, but suddenly it couldn't move at all. Could the sand hurt servos? 

2020-10-09 06:26:48
964415913
2020-10-12 10:25:22 Will Son

Hi,


The MX-64 does not provide protection from dust or particles as it does not have any IP rating.

Having foreign obstacles inside the DYNAMIXEL could damage the internal components.

Could you tell us the controller you are using, where can I find the example code you used, which USB interface you used to recover the firmware, QC numbers of MX-64?

Thank you.

2020-10-12 10:25:22
willson
2020-10-13 06:37:13 Yifeng

I am using the opencm 9.04 as controller. The example code I tested was the 'Dynamixel' example in Robotis. Only one or two examples would work on these four MX-64, however, example codes worked well on another intact MX-64. The USB interface is U2D2. I don't know the exact QC numbers. But I saw QC1948 on the U2D2. 


Thanks for your time and help.

2020-10-13 06:37:13
964415913
2020-10-13 14:47:55 Will Son

Hi,


It looks like you are using OpenCM IDE.

Please use Arduino IDE instead as OpenCM IDE is deprecated and not supported anymore.

You can find how to install Arduino IDE and OpenCM9.04 library from the eManual below.

https://emanual.robotis.com/docs/en/parts/controller/opencm904/#arduino-ide

Thank you.

2020-10-13 14:47:55
willson
Reply
웹에디터 시작 웹 에디터 끝