...
POST No. 2407998
robot arm joint effort controller of openmanipulator-p (in real robot) can not work!
2021-01-04 16:46:24 wangcj777

Using moveit planning to control the robot arm to move. Robot arm joint effort controller of openmanipulator-p in gazebo can work well,but when i run in the real robot arm, it can't work!
when i run the joint effort controller, the real robot arm can output torque. i can push it by my hand, then it will return to the origin position (just like a spring). but when i run the moveit to control it, it will lock each joint, and can't move!
we get the trajectory module warning:
[ WARN] [1607226630.131100399]: Controller arm_controller failed with error code PATH_TOLERANCE_VIOLATED
[ WARN] [1607226630.131192346]: Controller handle arm_controller reports status ABORTED
[ INFO] [1607226630.131209539]: Completed trajectory execution with status ABORTED ... 



i try to use a topic Publisher to control one joint, but it also can't work 

2021-01-04 16:46:24
wangcj777
2021-01-07 18:03:41 Will Son

Hi,

Thank you for your inquiry.

I'll request more information from the developer and get back to you.

Thank you for your patience.


=======Edited=======

Unfortunately, the examples available for OpenMANIPULATOR-P do not offer the effort controller.

If you need to use it, you'll need to create the controller for your purpose.

Thank you.

2021-01-07 18:03:41
willson
Reply
웹에디터 시작 웹 에디터 끝