...
POST No. 2408000
Use dynamixel with Jetson Nano
2021-01-08 17:38:14 dudwns6717

Hello,


When I try to control dynamixel motors using ros in jetson nano, there is some problem occurs.(I use U2D2). I follow the dynamixel-workbench tutorials. When I run the code on desktop and laptop, it works fine, but when I run it on Jetson Nano, an error occurs. I send an input value, then the motors move arbitrarily. This problem only occurs on Jetson Nano.

2021-01-08 17:38:14
dudwns6717
2021-01-08 17:53:34 Will Son

Hi,

Could you give us more details about what you've done such as lists of command you entered, DYNAMIXEL model name and settings?

Attaching a video clip that shows abnormal behavior would be greatly helpful.

Thank you.

2021-01-08 17:53:34
willson
2021-01-12 15:24:41 Kwon Yong Jun

I'm working with 6 motors(XM430-W210-R), baud rate is 2M, and loop rate is 10 Hz. My code works well on the computers and laptops.

But there is a problem when I run my code in NVIDIA Jetson Nano. So I took a video.


video link: https://youtu.be/NNU_kEci6zg


My video is tested with two XL430-W250-T motors. Baud Rate is 2M, 10Hz.(without 10Hz, I have the same results)


I follow the 'wheel operators' tutorial from here : https://emanual.robotis.com/docs/en/software/dynamixel/dynamixel_workbench/

I used two motors. I modified the code that the two motors can move respectively.


In video, you can check two motors. Right is number 1, Left is number 2.

When I give 0 value on angular velocity command to the number 1, the motor number 2 moves. But I didn't give any value to number 2 motor.

I don't know why this happened only on Jetson Nano.

comment
2021-01-20 12:10:52 microsystem
On Jetson nano, are you running kinetic or melodic ROS?
2021-01-20 12:10:52
microsystem
2021-01-12 15:24:41
dudwns6717
Reply
웹에디터 시작 웹 에디터 끝