POST No. 2408069
Cannot communicate/ping motors
2021-07-22 05:05:30 bryanwt


Need some help to debug some problems with some dynamixel motors. Please find the details of the motor and setup we are using along with the current symptoms.

Model: XM430-W350R

Setup: U2D2 for communication, Trossen Robotics - 6 Port RX/EX Power Hub, TTL connection wires.


1. The motor cannot be pinged/communicated with. We first tried with its previously used IDs and baud rates. We then tried all the Protocols, IDs and baudrates. We also tried this both via the API and the scan functionality on the Dynamical Wizard 2.0.
2. When connected to power, the red LED on the motors still blink. For me, this has always been the case even when the motor was working indicating that the motor is powered/on.
3. We tried doing a firmware recovery - but it did not work. Followed the instructions carefully, but the wizard could not continue after asking to restart the power to the motor. This makes sense to me as it cannot ping/communicate with the motor.

Thanks for your help and looking forward to hearing from you soon. Happy to provide more information if needed for diagnosis.

2021-07-22 05:05:30
2021-07-27 10:55:39 Will Son


I'm sorry about the delayed response.

You might have an identical ID among your connected DYNAMIXEL which interrupts communication between the Wizard 2.0 and DYNAMIXEL.

Have you connected only one DYNAMIXEL to the U2D2 during firmware recovery?

Are you supplying 12V to the power hub?

Some USB charging cables only transfers power, not data. Try with other USB cables.

Thank you.

2021-07-27 10:55:39
2021-07-27 18:57:21 Bryan


No worries and thanks for the response. To your questions above:

- Yes, we tried with each motor separately/individually as well both when trying to ping/communicate normally and for the firmware recovery process.
- Yes, we are supplying 12V to the power hub. 

We have also tried multiple USB cables in case of damage. To be clear, we have used these motors before and could successfully connect and control them. However, when using them one day - we had these issues and were unable to ping/communicate any of the motors since.

Thanks again for your time.

2021-07-27 18:57:21
2021-07-30 14:17:43 Will Son


Thank you for the updates.

It is very unlikely happening, but it seems like the RS485 communication IC is malfunctioning.

Since the LED blinks when powered, the bootloader works fine, but not responding during the firmware recovery process is mostly due to the problem in the communication part.

And you've already tested with various cables, the last thing I can suspect is the communication IC.

I'd recommend getting the RMA service for further inspection from our engineers to see if the PCB needs to be replaced.

Thank you.

2021-07-30 14:17:43
웹에디터 시작 웹 에디터 끝