...
POST No. 2408090
Problem with multiple dynamixel motors (MX-106) operation
2021-11-02 18:31:11 cbriaims

Dear Sir/Madam

I am using Arduino IDE for coding Open CM and expansion board for operating Dynamixel motor (MX-106). I have operated single motor successfully whereas multiple motors were not working when cascaded.

After that now when I am connecting Open CM with PC via USB a “USB device not recognised” error is coming (Screenshot attached). After few tries even if it gets connected, a simple code for printing “Hello World” into serial monitor of Arduino IDE is not getting executed. (code get compiled and uploaded successfully to the board).

What may be the problem? Kindly suggest!



2021-11-02 18:31:11
cbriaims
2021-11-03 13:08:45 Will Son

Hi,


You may try connecting the OpenCM9.04 under the Recovery Mode as described in the eManual below.

https://emanual.robotis.com/docs/en/parts/controller/opencm904/#recovery-mode 

This will ensure to run the bootloader during the boot up process if you have a problem in running the sketch code.

Once the bootloader is loaded, you can upload a new sketch on OpenCM9.04.


If you are using a multiport USB hub, try connecting the OpenCM9.04 directly to the USB port on the PC as some USB hubs may cause similar issues.


Thank you.

2021-11-03 13:08:45
willson
2021-11-05 16:26:23 CHANADAN KUMAR

Dear Sir,
Thanks for your quick response, updating the bootloader as you said worked fine. Now the open CM is working fine (individually). But when we are connecting Dynamixel motor to it via expansion board, the motors are not working but the code works well (except the motor running codes). We have tried firmware recovery for each motors still they are not operating.


kindly suggest solution for the same. Waiting for your valuable response.

2021-11-05 16:26:23
cbriaims
2021-11-10 16:22:26 Will Son

Hi,


Please make sure that the correct serial port is selected when using OpenCM9.04 with the OpenCM485EXP board.

Please refer to the comment in the example source code to find this out.

https://github.com/ROBOTIS-GIT/OpenCM9.04/blob/master/arduino/opencm_arduino/opencm9.04_release/libraries/OpenCM9.04/examples/07_DynamixelSDK/protocol2.0/read_write_mx/read_write_mx.ino#L26


The video instruction below might help.

https://youtu.be/OvmGwDDrdu0?t=435


Thank you.

2021-11-10 16:22:26
willson
Reply
웹에디터 시작 웹 에디터 끝