...
POST No. 2408093
Can't scan the XH540-V270-R using Wizard2.0 and OpenCR
2021-11-15 18:03:23 Hanchu

I use a 12V power to power the OpenCR which is connected with the laptop using USB transter line. Then I connect XH540-V270-R to OpenCR using the Matching 485 line. After the above steps I select all options in Wizard2.0 and Scan but it can't find the Servo. How should I use OpenCR and Wizard2.0 to simple control the servo. Thanks!

2021-11-15 18:03:23
Hanchu
2021-11-17 16:29:03 Will Son

Hi,


It is recommended to use the U2D2 in order to manage DYNAMIXEL with DYNAMIXEL Wizard 2.0.

If you wish to use OpenCR as a communication interface, you may use the usb_to_dxl arduino example

Please refer to the Option2 : Use OpenCR as a communication interface instruction in the OpenMANIPULATOR-X.


You may have to modify the DXL_BAUD to match the actual baud rate of your DYNAMIXEL.

If you haven't modified the baudrate of DYNAMIXEL, the factory value of XH540-V270-R is 57600.


Thank you.

2021-11-17 16:29:03
willson
2021-11-19 23:13:57 Hanchu
  1. Thank you for your explanation. Then I followed the steps in OpenCR 1.0 and Arduino IDE and  OpenMANIPULATOR-X, When I upload the program, It's always be uploading and errors occuring. How should I upload  examples such as model_scan and others successfully? Thank you!

     

2021-11-19 23:13:57
Hanchu
2021-11-22 10:48:40 Will Son

Hi,


I'm sorry about the delayed response.

If you need more prompt communication, please contact us at support@robotis.com


If the upload fails, try uploading again with the upload button or use the Recovery Mode.

When the Recovery mode is active, the Status LED on the OpenCR will start flickering.

 

Other OpenCR examples can also be uploaded in the same way.

Could you give us more information about the "model_scan" example?

Where can we find the example?

2021-11-22 10:48:40
willson
2021-11-22 12:36:51 Hanchu

Thank you very much for your detailed answer! I can upload the firmware successfully now but after I upload the example in “Examples > OpenCR> 08.DynamixelWorkbench> o_Find_Dynamixel” , I can't find the XH540-V270-R. And I find that When I only use the power supply and don't connect the USB, There are no LED lighting on the board as shown in figures. How can I find the dynamixel. 



 

2021-11-22 12:36:51
Hanchu
2021-11-22 13:23:44 Will Son

Hi,


When the OpenCR is connected to the PC with USB port, the USB LED should be turned on.

If none of the LED on the OpenCR works, the OpenCR may have been damaged and not functioning properly.

2021-11-22 13:23:44
willson
2021-11-22 17:45:39 Hanchu

LEDs are turned on if I connect the OPENCR to PC with USB port, But I can't find the dynamixel connected with the OPENCR using examples "Examples > OpenCR>08.DynamixelWorkbench> o_Find_Dynamixel”. If I only connect the power and don't connect the OPENCR to PC, it doesn't have led turned on.

comment
2021-11-23 10:51:53 willson
Please check if the fuse in the back of the OpenCR blew up.
If it is blown up, the power from from the battery or SMPS will be cut off.
http://en.robotis.com/shop_en/item.php?it_id=903-0178-000
2021-11-23 10:51:53
willson
2021-11-23 15:57:52 Hanchu
Thank you! The fuse did blow up.
2021-11-23 15:57:52
Hanchu
2021-11-22 17:45:39
Hanchu
Reply
웹에디터 시작 웹 에디터 끝